Tuesday, July 6, 2010

Change time zone in aix

Stop xntp service if your server is an ntp client.

# stopsrc -s xntpd
Change time zone to IST CUT +5:30 using command

# chtz IST-5:30
Login/logout. nullify your drift file after taking a backup

# > /etc/ntp.drift

Set correct time using

# smitty date
Restart xntpd

# startsrc -s xntpd

AIX commands

Displaying the top 10 CPU-consuming processes

# ps aux | head -1; ps aux | sort -rn +2 | head -10

Displaying number of processors in the system

# lsdev -Cc processor

Displaying the top 10 CPU-consuming processes

# ps aux | head -1 ; ps aux | sort -rn +3 | head

Displaying the top 10 memory-consuming processes using SZ

# ps -ealf | head -1 ; ps -ealf | sort -rn +9 | head

Displaying the processes in order of being penalized

# ps -eakl | head -1 ; ps -eakl | sort -rn +5

Displaying the processes in order of priority

# ps -eakl | sort -n +6 | head

Displaying the processes in order of nice value

# ps -eakl | sort -n +7

Displaying the processes in order of time

# ps vx | head -1 ; ps vx | grep -v PID | sort -rn +3 | head -10

Displaying the processes in order of real memory use

# ps vx | head -1 ; ps vx | grep -v PID | sort -rn +6 | head -10

Displaying the processes in order of I/O

# ps vx | head -1 ; ps vx | grep -v PID | sort -rn +4 | head -10

Displaying WLM classes

# ps -a -o pid,user,class,pcpu,pmem,args

Determining the PID of wait processes

# ps vg | head -1 ; ps vg | grep -w wait

Wait processes bound to CPUs

# ps -mo THREAD -p 516,774,1032,1290

Aix: Unlock user account AIX

Procedure to change the password on a server

# passwd

Note: The account needs to be reset if when trying to log in the following message is received:

3004-303 There have been too many unsuccessful login attempts; please see
the system administrator.

Procedure to reset the account:

# chsec -f /etc/security/lastlog -a \
"unsuccessful_login_count=0" -s

# chuser "account_locked=false"


on the other hand, edit this file:
# vi /etc/security/lastlog

and reset this field to zero: unsuccessful_login_count = 0